This lists the versions of Ingenico firmware that are compatible with Counterpoint, and the supported minimum and maximum versions of Counterpoint for each RBA firmware version.

  • 14.06
    • Minimum: 8.4.6.13 (because this is the minimum for Secure Pay)
    • Maximum: 8.5.3 (from 8.5.4.0 patch release notes)
  • 15.06
    • Minimum: 8.4.6.18
    • Maximum (EMV only): 8.5.4.0 (from 8.5.4.1 patch release notes)
    • Maximum (non-EMV only): none (from 8.5.4.1 patch release notes)
    • For non-EMV devices and unless EBT is needed, this is the highest version allowed
    • For non-EMV and non-EB, do NOT upgrade past this version, per 8.5.6.4 patch release notes.
  • 18.04 – required for EBT
    • Minimum: 8.5.2.1
    • Maximum (EMV only): 8.5.4.0 (from 8.5.4.1 patch release notes)
    • Maximum (non-EMV only): none (from 8.5.4.1 patch release notes)
  • 23.01 / 23.02 – (for EMV only)
    • Minimum: 8.5.4.1
    • Maximum: none
  • 23.0.44 - for EMV only
    • Minimum: 8.5.6.4 (8.5.6.4 patch release notes)
    • Maximum: none
    • Notes:
      • Only applies to KP4 devices on 23.02
      • Only applies to iSC250/iSMP4/iPP320 devices. Does NOT apply to Lane/5000 devices.